Libre-Office et les pdf

Mots-clés: mises à jour successives du système, passage d'openoffice à libreoffice, libexttextcat-data…

Abstract

Système testé: ubuntu 10.04, openoffice installé, puis désinstallé au profit de libreoffice.

Il existe de bons lecteurs de pdf sous ubuntu dont evince, mais ils ne permettent pas de modifier le contenu des pdf. Ce document traite de la possibilité d'importer des pdf dans le module draw (dessin) de libre office, et ce afin de les modifier.

Quand tout va bien, on peut ouvrir tout pdf avec Libreoffice qui utilisera alors son application de dessin Draw.

Quand ça ne marche pas ? Le bug libexttextcat-data qui peut donner lieu à des soucis: son installation oblige à désinstaller Libreoffice, voire interdit ensuite toute installation, que ce soit de Libreoffice ou d'Openoffice.

Openoffice vs Libreoffice

Quelle version avons nous ? Openoffice ou Libreoffice ?

http://doc.ubuntu-fr.org/openoffice.org

Depuis la version 12.04 LTS openoffice.org installe sans en avertir l'utilisateur le logiciel libreoffice

http://doc.ubuntu-fr.org/libreoffice

Extension intégrée ou pas ?

Sur les versions récentes de libreoffice, l'extension est intégrée dans les paquets, et n'apparaît pas en tant que telle dans synaptic.

Pdfimport

Openoffice

Sous openoffice une extension pdfimport existe…

Libre office

Sous libre-office, cette extension est paraît-il intégrée au logiciel

* Elle n'est pas disponible sur le site libre office… * Elle n'est pas présente dans les dépôts d'Ubuntu …pour lucid, en particulier, à vérifier pour les autres… * Ajouter le ppa libre office ne la fait pas apparaître dans les dépôts …

Il s'avère qu'il s'agit d'un bug bug lié à la distribution Ubuntu, en effet il ne se produit pas avec la version windows de Libre Office.

Solutions

Il semble que depuis la version 12.04, le bug soit corrigé !

Cohabiter

Les deux suites bureautiques seront installées et on n'utilisera qu' Open office pour importer des pdf …Ce n'est pas forcément le plus pratique.

Utiliser une seule suite est plus simple et n'oblige pas à gérer deux logiciels quasi équivalents en même temps.
Depuis synaptic, le choix de l'un entraîne la désinstallation de l' autre et vice-versa.

Open office et Libre office en même temps ? C'est possible à la condition d'effectuer une installation manuelle.

Installer manuellement LibreOffice

Voir dans la partie Annexes 2, la façon d'installer depuis un ppa !
On évite ainsi le bug lié aux paquets Libre office présents dans Ubuntu.

On devrait ainsi avoir l'extension pdfimport fonctionnelle après cette installation.

Procédure

Prérequis: savoir installer un logiciel manuellement…

Se rendre sur le site de l' éditeur Libreoffice

Télécharger le paquet deb. La version recommandée est la 3.5.5 en août 2012 …3-5-5

- L'ouvrir puis l'extraire avec le gestionnaire d'archives (clic droit). - Lancer depuis l' archive extraite l'installeur… - En principe cela se fait automatiquement.

Autre piste: abiword

La petite suite bureautique libre gérerait nativement l' import de pdf …

http://doc.ubuntu-fr.org/abiword

En anglais

Récupérer le paquet libreoffice-pdfimport

|ask.libreoffice.org

In Ubuntu Lucid the libreoffice-pdfimport package is somehow unavailable in the libreoffice ppa. Installing the extension directly from the project page worked.

Nombreux commentaires négatifs: difficulté à installer, non fonctionnement

Parallel install

Do a parallel install of 3.5.3 Installing_in_parallel

Delete your current pdfimport folder under <yourlo install=“”>\share\extensions\ and copy the folder from the 3.5.3 share\extensions You might need to execute LO two or three times to allow it to add PDFimport to the list of extensions ;)

Tested with version 3.6.0alpha0+ (Build ID: 8a78020) under Win XP Pro x86 SP3

Télécharger pdfimport

Versions 32 bits

Il semble essentiel d'utiliser la version pour votre distribution.
La version natty ne fonctionne pas sous Lucid (10.04) dépendance libpoppler13 non satisfaite…

Remarque: Ces liens sont mis pour mémoire, on peut aussi choisir les onglets [nom_de_la_distrib] [updates], et en lisant cette page vous en apprendrez plus.

Natty (11.04)

Oneiric 11.10

Paquets similaires

* openoffice.org-pdfimport * libfpdi-php * libreoffice-writer2latex * libpdfbox-java * pdfmod * libpdfbox-java-doc * pdftk * libpdf-writer-ruby1.8 * libreoffice-writer2xhtml * lo-menubar * libpdf-writer-ruby-doc

Installer libre office depuis le ppa

Via le PPA, cette méthode permet :

* d'installer LibreOffice sur Ubuntu 10.04 LTS ; * d'obtenir une version récente et stable de LibreOffice sur Ubuntu 11.04 et suivantes.

Procédure

* ppa:libreoffice/libreoffice-3-51) pour la version 3.5 considérée comme stable par the Document Foundation, ou ppa:libreoffice/ppa pour la toute dernière version (branche 3.6) ; * rechargez la liste des paquets ; * installez le paquet libreoffice ; * Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'aide, installez le paquet d'internationalisation libreoffice-l10n-XX, par exemple pour fr : libreoffice-l10n-fr

libexttextcat-data

Ce paquet reste proposé dans les mises à jour, mais en grisé.

Libreoffice a disparu de mon mon ordinateur aprés une mise a jour

Piste: L'installation ou la mise à jour de Libreoffice via le ppa de la doc n'est pas possible à cause d'une erreur de dépendance dont le fautif est le paquet « libexttextcat ».

bugs.freedesktop_Mismatch version between libexttextcat0 and libexttextcat-data

dependency issues

While pulling the daily updates, I had “libexttextcat-data” available for upgrade. However the upgrade suggests removal of several packages including libreoffice-core, libreoffice-calc, libreofice-writer, etc.

Les versions d'Ubuntu

Ubuntu 10.04 LTS The Lucid Lynx (le lynx lucide) 29 avril 2010 Avril 2013 Avril 2015 Ubuntu 11.04 The Natty Narwhal (le narval chic) 28 avril 2011 Octobre 2012 Ubuntu 11.10 The Oneiric Ocelot (l'ocelot onirique) 13 octobre 2011 Avril 2013 Ubuntu 12.04 LTS The Precise Pangolin (le pangolin précis) 26 avril 2012 Avril 2017

Liens

libreoffice_et_pdfimport.txt · Dernière modification: 2013/05/11 15:16 (modification externe)
GNU Free Documentation License 1.3
Powered by PHP Driven by DokuWiki Recent changes RSS feed Valid CSS Valid XHTML 1.0 Valid HTML5