Icaunux - Le Forum

Forum de l'Association ICAUNUX

Vous n'êtes pas identifié(e).

Annonce

Les Inscriptions au forum sont temporairement désactivées en attendant de trouver une solution efficace contre les inscriptions fictives très nombreuses ces derniers temps. Si vous souhaitez vous inscrire sur le forum, merci d'envoyer une demande par mail à l'adresse contact@icaunux.org. Désolé de cette gène occasionnée.

#1 18-05-2022 19:14:14

wanica
Membre
Inscription : 13-11-2008
Messages : 2 024

pulseaudio pas de son lubuntu 18.04 32b

no more sound pulseaudio lubuntu 18.04

https://askubuntu.com/questions/1081748 … untu-18-04
réponse une
I had the same problem and this commands worked for me.
Socket is enabled by default:

$ systemctl --user status pulseaudio.socket

If you want pulseaudio to start right after login: $ systemctl --user enable pulseaudio

réponse deux
First try to remove and install again drivers.
sudo apt-get remove alsa-base pulseaudio

 sudo apt remove alsa-base pulseaudio
Le paquet « pulseaudio » n'est pas installé, et ne peut donc être supprimé Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  linux-sound-base Veuillez utiliser « sudo apt autoremove » pour le supprimer.
Les paquets suivants seront ENLEVÉS :
  alsa-base
Après cette opération, 475 ko d'espace disque seront libérés.

Suppression de alsa-base (1.0.25+dfsg-0ubuntu5) ...

sudo apt-get install alsa-base 
user @ user MS-7309:~$ sudo apt install alsa-base
Paquets suggérés :  apmd alsa-oss oss-compat
Les NOUVEAUX paquets suivants seront installés :  alsa-base  

and force again alsa loading:
sudo alsa force-reload

 sudo alsa force-reload
[sudo] Mot de passe de user
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-seq-midi snd-hda-core snd-seq-midi-event snd-hwdep snd-rawmidi snd-pcm snd-seq snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-timer).

Loading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-seq-midi snd-hda-core snd-seq-midi-event snd-hwdep snd-rawmidi snd-pcm snd-seq snd-seq-device snd-timer.

It wasn't enough for me, so I'd to remove the directory for creating a new one.

mv ~/.config/pulse ~/.config/old_pulse

Réinstaller pulseaudio

s paquets supplémentaires suivants seront installés : 
  libpulsedsp pulseaudio-utils rtkit
Paquets suggérés :
  pavumeter paman paprefs ubuntu-sounds

Reboot for creating the new files automatically, and it should work.

https://bbs.archlinux.org/viewtopic.php?id=249978

I can't access pulsemixer nor do i hear anything even though pulseaudio.service is running.
When I stop pulseaudio.service and run pulseaudio myself, everything works.
I've already reinstalled pulseaudio and have the default configuration.

aide plus pointue mais plus complexe

systemctl --user status pulseaudio.socket
● pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; disabled; vendor pre
   Active: inactive (dead)
   Listen: /run/user/1000/pulse/native (Stream)
lines 1-4/4 (END)

https://net2.com/how-to-fix-sound-issue … ntu-18-04/

n such situations, it might be related to a permission issue with the pulseaudio config file. Try to run the commands below in order to fix this :

killall pulseaudio; rm -r ~/.config/pulse/*


Pavucontrol installation

Since PulseAudio doesn’t allow to control each playback stream separately, Pavucontrol provides you with more control over your audio devices, so that you will be able to tweak your headphone or speaker more precisely.


 printenv DBUS_SESSION_BUS_ADDRESS
unix:path=/run/user/1000/bus
user@userMS-7309:~$ pulsemixer

La commande « pulsemixer » n'a pas été trouvée, mais peut être installée avec :

sudo snap install pulsemixer  # version 1.5.1, or
sudo apt  install pulsemixer

Voir « snap info pulsemixer » pour des versions additionelles.

user@user:~$ pulseaudio –start
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/user/.config/pulse//daemon.conf': Permission non accordée
W: [pulseaudio] daemon-conf.c: Échec lors de l'ouverture du fichier de configuration : Permission non accordée
user@user:~$ sudo pulseaudio –start
[sudo] Mot de passe de user
pulseaudio –start
E: [pulseaudio] main.c: Too many arguments.

user@user-MS-7309:~$ sudo pulseaudio – start
E: [pulseaudio] main.c: Too many arguments.

user@user:~$ sudo -i
root:~# pulseaudio -start
pulseaudio : option invalide -- 's'

tester autre chose ?
pavucontrol
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/user/.config/pulse//daemon.conf': Permission non accordée

Marche pas

Supprimer pulseaudio

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libpulsedsp pulseaudio-utils rtkit
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  pulseaudio
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Après cette opération, 4190 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
sudo apt autoremove
Les paquets suivants seront ENLEVÉS :
  libpulsedsp pulseaudio-utils rtkit

Hors ligne

#2 21-05-2022 18:34:26

IceCat
Membre
Lieu : 93
Inscription : 17-11-2012
Messages : 655

Re : pulseaudio pas de son lubuntu 18.04 32b

Hum, avec alsa, il faut que l'utilisateur soit dans le groupe "audio" pour avoir le droit de gérer le son. C'est bien le cas ?

Ensuite, je ne sais pas vraiment pour Ubuntu 18.10 car ça devient très vieux, mais maintenant il y a aussi un service "sound.target" qui démarre lorsqu'une carte est détectée. Ça dit quoi "systemctl status sound.target" ?

Enfin, pour démarrer pulseaudio à la main c'est "pulseaudio --start", il manque un tiret. Ensuite s'il a l'air de démarrer, tu as aussi "pulseaudio --check" qui permet de savoir s'il est OK ou pas. Par contre, pour le savoir il faut récupérer le code de retour de la commande. Donc après le check, il faut faire "echo $?". Si ça te renvoi 0 c'est que c'est bon. Si autre chose que 0, ce n'est pas bon.


promotion.php?image=PL-user.png&membre=IceCat

Hors ligne

#3 23-05-2022 17:33:06

wanica
Membre
Inscription : 13-11-2008
Messages : 2 024

Re : pulseaudio pas de son lubuntu 18.04 32b

Merci de tes commentaires.

Oui mais en 32 bits, la 18.04 est la dernière disponible/
La carte son fonctionne en lecture de fichiers son, mais pas dans firefox (video en ligne)

J'ai vérifié l 'historique des commandes  et j'avais entré la commande avec et sans les deux tirets, ce qui ne changeait rien. Je viens de recommencer:

pulseaudio --start 
W: [pulseaudio] core-util.c: Failed to open configuration file '/home/user/.config/pulse//daemon.conf': Permission non accordée
W: [pulseaudio] daemon-conf.c: Échec lors de l'ouverture du fichier de configuration : Permission non accordée  

Avec sudo

sudo pulseaudio --start 
W: [pulseaudio] main.c: Le programme n'est pas conçu pour être lancé en tant que root (sauf si --system est renseigné). 

Avec sudo -i
#

pulseaudio --start 
W: [pulseaudio] main.c: Le programme n'est pas conçu pour être lancé e est la dernière dispontant que root (sauf si --system est renseigné).
E: [pulseaudio] main.c: Échec lors du démarrage du démon 
systemctl --user status pulseaudio.socket
● pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; disabled; vendor preset: enabled)
   Active: inactive (dead)
   Listen: /run/user/1000/pulse/native (Stream) 

ligne 3 pulseaudio.socket; disabled   désactivé ??
Ligne 4 inactive ( dead)  !!
Comment se fait-ce ?

https://askubuntu.com/questions/1071532 … ystem-mode

askubuntu.com a écrit :

While troubleshooting a problem with VMWare disconnecting audio device during Ubuntu boot (18.04.1 LTS Ubuntu Desktop), I have isolated the problem to be systemd running pulseaudio in system mode before the login screen show up. pulseaudio runs in user mode just fine after logging in, and that is what I need.

My question is how to disable pulseaudio (which is part of sound.target) in systemd, before the user login screen.

Il veut faire le contraire de ce que je cherche...
sudo -i

 #pulseaudio --check 
root@user:~# echo $?
1 

Donc le 1 ce n'est pas bon.

/etc/pulse/client.conf
toutes lignes ont un ;  devant   autospawn=no  ( mais yes sur une config fonctionnelle en 64 b)

/home/user/.config a un dossier Pulse qui contient un fichier cookie ainsi que des fichiers
default-sink  default-source...dbd-card-database etc
qui sur la conf fonctionnelle 64 bits sont dans le dossier /home/user/.pulse ( à part le cookie).. et d'ailleurs elle a plus de fichiers dans ce dossier

La conf en défaut n' a pas ce dossier .pulse immédiatement dans le répertoire utilisateur.

Bizarrement, le .Pulse de  /home/user/.config était possédé par root et non par user !! Ce que j'ai modifié.
ça ne change rien.

Hors ligne

#4 26-05-2022 02:40:23

IceCat
Membre
Lieu : 93
Inscription : 17-11-2012
Messages : 655

Re : pulseaudio pas de son lubuntu 18.04 32b

Dans tes tests avec --start, il te disait soit qu'il fallait pas le lancer en root, soit qu'il arrivait pas à lire le fichier de conf.
Maintenant que tu as corrigé le problème de droits, il dit quoi ?

J'ai bien un dossier pulse dans .config, il contient aussi un cookie mais également des fichiers .tdb (je ne sais pas ce que c'est comme base de données).

Ton pulseaudio.socket est désactivé parce qu'il est mort.
L'user est bien dans le groupe audio ?
Il a quel statut ton service sound.target (si tu l'as) ?
T'as des messages dans /var/log/messages quand tu fais un systemctl restart pulseaudio.socket ? En user et/ou en root ?


promotion.php?image=PL-user.png&membre=IceCat

Hors ligne

#5 03-06-2022 08:09:19

wanica
Membre
Inscription : 13-11-2008
Messages : 2 024

Re : pulseaudio pas de son lubuntu 18.04 32b

IceCat a écrit :

Dans tes tests avec --start, il te disait soit qu'il fallait pas le lancer en root, soit qu'il arrivait pas à lire le fichier de conf.
Maintenant que tu as corrigé le problème de droits, il dit quoi ?

Rien de plus...

IceCat a écrit :

L'user est bien dans le groupe audio ?

Je pense que oui...J'ai plusieurs configurations où l'user n'est pas autorisé à utiliser des périphériques audio mais peut utiliser l'audio quand même.

IceCat a écrit :

Il a quel statut ton service sound.target (si tu l'as) ?

systemctl status sound.target  
Loaded: loaded (/lib/systemd/system/sound.target; static; vendor preset: enab
   Active: active 
IceCat a écrit :

T'as des messages dans /var/log/messages quand tu fais un systemctl restart pulseaudio.socket ? En user et/ou en root ?

En user comme en root (soit en sudo -i soit en sudo devant la commande):

Failed to restart pulseaudio.socket: Unit pulseaudio.socket not found. 

J'avais déjà restauré le son sur ce pc, mais je ne me rappelle plus exactement comment, il me semble en ayant réinstallé le meta paquet lxde ou lubuntu...

Hors ligne

#6 04-06-2022 16:33:03

IceCat
Membre
Lieu : 93
Inscription : 17-11-2012
Messages : 655

Re : pulseaudio pas de son lubuntu 18.04 32b

Que donne :

systemctl --user status pulseaudio.socket

Après avoir fait ceci :

sudo apt-get install alsa-base pulseaudio
sudo alsa force-reload
systemctl --user enable pulseaudio

promotion.php?image=PL-user.png&membre=IceCat

Hors ligne

#7 08-06-2022 10:52:57

wanica
Membre
Inscription : 13-11-2008
Messages : 2 024

Re : pulseaudio pas de son lubuntu 18.04 32b

sudo apt-get install alsa-base pulseaudio 

alsa-base est déjà la version la plus récente (1.0.25+dfsg-0ubuntu5).
pulseaudio est déjà la version la plus récente (1:11.1-1ubuntu7.11).
sudo alsa force-reload
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-seq-midi snd-hda-intel snd-seq-midi-event snd-rawmidi snd-hda-codec snd-hda-core snd-hwdep snd-seq snd-pcm snd-seq-device snd-timer (failed: modules still loaded: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-hda-intel snd-hda-codec snd-hda-core snd-hwdep snd-pcm snd-timer).
Loading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-codec-generic snd-hda-codec-hdmi snd-seq-midi snd-hda-intel snd-seq-midi-event snd-rawmidi snd-hda-codec snd-hda-core snd-hwdep snd-seq snd-pcm snd-seq-device snd-timer.
systemctl --user enable pulseaudio
Created symlink /home/user/.config/systemd/user/default.target.wants/pulseaudio.service → /usr/lib/systemd/user/pulseaudio.service.
Created symlink /home/user/.config/systemd/user/sockets.target.wants/pulseaudio.socket → /usr/lib/systemd/user/pulseaudio.socket.
 systemctl --user status pulseaudio.socket
● pulseaudio.socket - Sound System
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.socket; enabled; vendor pres
   Active: inactive (dead)
   Listen: /run/user/1000/pulse/native (Stream)

encore inactive: dead...

Hors ligne

#8 09-06-2022 23:36:53

IceCat
Membre
Lieu : 93
Inscription : 17-11-2012
Messages : 655

Re : pulseaudio pas de son lubuntu 18.04 32b

Bon c'est installé, alsa reloadé, et la socket enable.

Et maintenant, après un reboot ou si on le démarre (systemctl --user restart pulseaudio.socket) ? Toujours dead ?


promotion.php?image=PL-user.png&membre=IceCat

Hors ligne

Pied de page des forums